Connections to .NA and Donuts tlds are experiencing issues

Minor incident Web Apps DNS Portal (portal.dns.business) Gateway API EPP
2020-03-20 07:05 UTC · 2 weeks, 3 days, 8 hours, 30 minutes, 47 seconds

Updates

Resolved

Issue with NA is resolved

April 6, 2020 · 15:36 UTC
Update

Donuts connectivity restored late last night however .NA is still currently experiencing issues which will only be resolved on Monday with the NA Registry.

March 21, 2020 · 07:52 UTC
Update

We have confirmed its not a routing issue for Donuts and .NA and have logged a support request at both registries

March 20, 2020 · 11:04 UTC
Issue

Our team is aware of intermittent connectivity issues and are investigating

March 20, 2020 · 07:15 UTC

← Back