MCB Merchant Services Payment Processing Unavailable

Minor incident Web Apps Gateway SRS Portal
2024-08-05 06:54 SAST · 1 day, 22 minutes

Updates

Resolved

Payment issues with our provider are resolved.

August 6, 2024 · 07:17 SAST
Investigating

Some ACS servers are not activating the 3DS step in the payment process, though some payments are being processed normally.

August 5, 2024 · 10:20 SAST
Issue

We regret to inform you that MCB Merchant Services is currently experiencing a temporary downtime, and we are unable to process payments at this time. Our technical team is actively working to resolve the issue as quickly as possible.

Impact:

  • Inability to process payments through MCB Merchant Services.
  • Potential delays in transaction approvals and settlements.

Estimated Time to Resolution:
We are striving to restore full service within the next 2 hours. We will provide updates as more information becomes available.

We apologize for any inconvenience this may cause and appreciate your understanding and patience as we work to resolve this issue. For urgent inquiries, please contact our customer support team at support@dns.business.

August 5, 2024 · 06:54 SAST

← Back