ZACR Payment issues with Wirecard

Minor incident Web Apps ZACR Portal (portal.registry.net.za)
2020-08-17 09:19 UTC · 1 week, 6 days, 21 hours, 25 minutes, 20 seconds

Updates

Resolved

The intermittent transactional processing issues at Wirecard have been resolved. We will continue to monitor the payments.

August 31, 2020 · 06:45 UTC
Investigating

Please note our upstream provider (Wirecard) is still investigating intermittent 3DS payment issues on their system. This affects topup payments for ZACR.

August 26, 2020 · 07:13 UTC
Issue

We’re currently experiencing intermittent 3D Secure issues. Wirecard engineers are investigating and aim to resolve this as soon as possible. ZACR Payments affected.

August 17, 2020 · 09:21 UTC

← Back