EPP failures reported

Major incident EPP
2019-11-28 10:48 SAST · 51 minutes, 11 seconds

Updates

Resolved

EPP issues are resolved

November 28, 2019 · 11:39 SAST
Investigating

We are aware of the EPP connection failures some clients are reporting. Our engineers are on site investigating.

November 28, 2019 · 10:50 SAST

← Back