Web-Rar domain create issue

Minor incident Web Apps DNS Portal (portal.dns.business)
2020-02-13 09:51 SAST · 2 hours, 55 minutes, 14 seconds

Updates

Resolved

Domain create issue has been resolved. Small bug with the latest update

February 13, 2020 · 12:46 SAST
Issue

We are aware of an issue with domain creates in Portal, we are investigating.

February 13, 2020 · 09:52 SAST

← Back